Перейти к содержимому
Xacan - вернись на форум! Я все прощу!
Я халвы тебе без транс-жиров ссыщу!

Архивировано

Эта тема находится в архиве и закрыта для публикации сообщений.

Гость Franky

Эксель

Recommended Posts

Гость Franky

Вокруг люди такие сурьезные темы обсуждают, линухи там всякие, перфорсы, прям неловко даже постиццо в ветке :wacko:

Везло мне наверное, но на всех работодателях учет велся в лучшем случае в эксельке, в худшем - в недоделанной ERP.

Собственно, вопрос по сабжу:

есть необходимость при суммировании по условию - функция СУММЕСЛИ() - проверять не одно, а два (и более?) условия. Например, вытаскивать из таблицы

[Дата] [=год(дата)] [=месяц(дата)] [значение]

сумму значений с определенными параметрами года и месяца.

Знает ли кто-либо не очень извратный способ это сделать?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость Itbankir

Если все на одном листе, то наложи фильтр и используй: ПРОМЕЖУТОЧНЫЕ.ИТОГИ(9;[диапазон])

Если это не устроит, то добавь на лист с суммируемыми значениями еще один столбец, в которые слепи в одну строку все условия и делай суммесли по этому столбцу.

Если и это не устроит, то выкладывай книгу.xls с тестовыми данными, посмотрим.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость Shаdow

синтаксис

=СУММПРОИЗВ((условие1)*(условие2)*(что_суммировать))

пример

=СУММПРОИЗВ(($A$1:$A$10=$F3)*($B$1:$B$10=$G3)*($C$1:$C$10))

а1-а10 - год

б1-б10 - месяц

с1-с10 - какоето значение соответствующее году и месяцу

ф3 - ячейка содержащая критерий с чем сравнивать год (или тупо вбить числом в формуле)

г3 - тож самое с месяцем

Добавлено в [mergetime]1256744511[/mergetime]

если условие не выполняется - оно фалсе и возвращает ноль - то произведение равно нулю, соответственно ничо не суммируется, далее опрашивается следущая ячейка диапазона. цикл короче.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость Franky
синтаксис

=СУММПРОИЗВ((условие1)*(условие2)*(что_суммировать))

пример

=СУММПРОИЗВ(($A$1:$A$10=$F3)*($B$1:$B$10=$G3)*($C$1:$C$10))

а1-а10 - год

б1-б10 - месяц

с1-с10 - какоето значение соответствующее году и месяцу

ф3 - ячейка содержащая критерий с чем сравнивать год (или тупо вбить числом в формуле)

г3 - тож самое с месяцем

Добавлено в  [mergetime]1256744511[/mergetime]

если условие не выполняется - оно фалсе и возвращает ноль - то произведение равно нулю, соответственно ничо не суммируется, далее опрашивается следущая ячейка диапазона. цикл короче.

У меня была мысля делать как предыдущий оратор - преобразовывать оба условия в текст, сцеплять текст и по этому совокупному "составному" условию делать суммуесли - но чует мой кормовой резонатор, после второй сотни записей на листе пересчет формул будет занимать по 5 минут, а потенциальное количество записей - по 2 тыщи на каждом из двух десятков листов, со сводом итогов в один лист.

Умножение в этом плане будет шустрее, попробую завтра, спасибо за идею :)

Пы.Сы. Дико нехватает теории по всяким БД, знаю что весь энтот изврат легко хранится и обрабатывается в Access, но все попытки были плачевны, путаюсь в связях таблиц :P(

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

вообще-то для подобных целей используют формулы массивов

на вскидку, для твоего примера должно что-то типа так:

{=СУММ(ЕСЛИ(B1:B10=E1;ЕСЛИ(C1:C10=F1;D1:D10)))}

где b1:b10 - диапазон "ГОД", e1 - вводимое значение искомого года

c1:c10 - диапазон "МЕСЯЦ", f1 - вводимое значение искомого месяца

d1:d10 - диапазон суммируемых величин

формула массива вводится посредством Ctrl+Shift+Enter

есть вопросы?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость Franky
есть вопросы?

Принцип понятен, но что-то моя экселька не хочет формулы массивов за формулы считать;) Причем в хелпе эти функции описаны. Их случаем не в 2007м офисе ввели?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

С какой версии формулы массивов были введены я не знаю, но работал я с ними ещё в 2000 офисе. Сейчас юзаю ХР. Всё работает.

могу файлик примера выслать (если нужно).

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость Franky
С какой версии формулы массивов были введены я не знаю, но работал я с ними ещё в 2000 офисе. Сейчас юзаю ХР. Всё работает.

могу файлик примера выслать (если нужно).

Если не трудно, почта franky4746@mail.ru

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Срочно требуется специалист, отлично знающий программу Excel (продвинутый пользователь). Работа со сводными таблицами. График работы свободный. З/п 150 руб./час.

Контактная информация:

Адрес: ул. Колетвинова, 6, оф.37/4 (5м от остановки, рядом с Центральным рынком).

Тел.: 8(4872)361-243, 8-953-436-35-39.

Skype: soyuztula

E-mail: soyuztula@mail.ru

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

×
×
  • Создать...